CRAN Package Check Results for Package BiocManager

Last updated on 2019-11-16 00:51:01 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.30.9 2.78 106.50 109.28 ERROR
r-devel-linux-x86_64-debian-gcc 1.30.9 1.85 83.01 84.86 ERROR
r-devel-linux-x86_64-fedora-clang 1.30.9 99.44 NOTE
r-devel-linux-x86_64-fedora-gcc 1.30.9 91.64 NOTE
r-devel-windows-ix86+x86_64 1.30.9 12.00 71.00 83.00 OK
r-patched-linux-x86_64 1.30.9 2.19 73.55 75.74 OK
r-patched-solaris-x86 1.30.9 61.30 OK
r-release-linux-x86_64 1.30.9 2.25 101.48 103.73 OK
r-release-windows-ix86+x86_64 1.30.9 8.00 70.00 78.00 OK
r-release-osx-x86_64 1.30.9 NOTE
r-oldrel-windows-ix86+x86_64 1.30.9 8.00 50.00 58.00 OK
r-oldrel-osx-x86_64 1.30.9 NOTE

Check Details

Version: 1.30.9
Check: tests
Result: ERROR
     Running 'testthat.R' [42s/51s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(BiocManager)
     >
     > .skip_if_misconfigured <-
     + function()
     + {
     + if (!"BiocVersion" %in% rownames(installed.packages()))
     + return(NULL)
     +
     + R_version <- getRversion()
     + bioc_version <- packageVersion("BiocVersion")[, 1:2]
     + if (R_version == "4.0.0" && bioc_version == "3.9")
     + skip("mis-configuration, R 4.0, Bioc 3.9")
     + }
     >
     > .skip_if_BiocVersion_not_available <-
     + function()
     + {
     + if (!"BiocVersion" %in% rownames(installed.packages()))
     + skip("BiocVersion not installed")
     + }
     >
     > test_check("BiocManager")
     -- 1. Error: .install_repos() works (@test_install.R#28) ----------------------
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories()
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     -- 2. Error: .install_github() works (@test_install.R#35) ---------------------
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories()
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     -- 3. Error: repositories() returns all repos (@test_repositories.R#7) --------
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_true(all(allOS %in% names(repositories())))
     5. BiocManager::repositories()
     6. BiocManager:::.version_validate(version)
     8. BiocManager:::.stop(txt)
    
     -- 4. Error: repositories() does not return any NA repos (@test_repositories.R#1
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_true(!anyNA(repositories()))
     4. BiocManager::repositories()
     5. BiocManager:::.version_validate(version)
     7. BiocManager:::.stop(txt)
    
     -- 5. Error: repositories() returns expected order (@test_repositories.R#19) --
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_identical("BioCsoft", names(repositories())[[1]])
     4. BiocManager::repositories()
     5. BiocManager:::.version_validate(version)
     7. BiocManager:::.stop(txt)
    
     -- 6. Error: 'site_repository=' inserted correctly (@test_repositories.R#26) --
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories(site_repository)
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     -- 7. Failure: BiocVersion version matches with .version_map() (@test_version.R#
     BiocVersion package version '3.10' does not match BiocManager::.version_map() '3.11'. Check configuration.
    
     == testthat results ===========================================================
     [ OK: 72 | SKIPPED: 2 | WARNINGS: 0 | FAILED: 7 ]
     1. Error: .install_repos() works (@test_install.R#28)
     2. Error: .install_github() works (@test_install.R#35)
     3. Error: repositories() returns all repos (@test_repositories.R#7)
     4. Error: repositories() does not return any NA repos (@test_repositories.R#13)
     5. Error: repositories() returns expected order (@test_repositories.R#19)
     6. Error: 'site_repository=' inserted correctly (@test_repositories.R#26)
     7. Failure: BiocVersion version matches with .version_map() (@test_version.R#176)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-devel-linux-x86_64-debian-clang

Version: 1.30.9
Check: tests
Result: ERROR
     Running ‘testthat.R’ [32s/53s]
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > library(testthat)
     > library(BiocManager)
     >
     > .skip_if_misconfigured <-
     + function()
     + {
     + if (!"BiocVersion" %in% rownames(installed.packages()))
     + return(NULL)
     +
     + R_version <- getRversion()
     + bioc_version <- packageVersion("BiocVersion")[, 1:2]
     + if (R_version == "4.0.0" && bioc_version == "3.9")
     + skip("mis-configuration, R 4.0, Bioc 3.9")
     + }
     >
     > .skip_if_BiocVersion_not_available <-
     + function()
     + {
     + if (!"BiocVersion" %in% rownames(installed.packages()))
     + skip("BiocVersion not installed")
     + }
     >
     > test_check("BiocManager")
     ── 1. Error: .install_repos() works (@test_install.R#28) ──────────────────────
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories()
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     ── 2. Error: .install_github() works (@test_install.R#35) ─────────────────────
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories()
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     ── 3. Error: repositories() returns all repos (@test_repositories.R#7) ────────
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_true(all(allOS %in% names(repositories())))
     5. BiocManager::repositories()
     6. BiocManager:::.version_validate(version)
     8. BiocManager:::.stop(txt)
    
     ── 4. Error: repositories() does not return any NA repos (@test_repositories.R#1
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_true(!anyNA(repositories()))
     4. BiocManager::repositories()
     5. BiocManager:::.version_validate(version)
     7. BiocManager:::.stop(txt)
    
     ── 5. Error: repositories() returns expected order (@test_repositories.R#19) ──
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. testthat::expect_identical("BioCsoft", names(repositories())[[1]])
     4. BiocManager::repositories()
     5. BiocManager:::.version_validate(version)
     7. BiocManager:::.stop(txt)
    
     ── 6. Error: 'site_repository=' inserted correctly (@test_repositories.R#26) ──
     Bioconductor version '3.10' requires R version '3.6'; see
     https://bioconductor.org/install
     Backtrace:
     1. BiocManager::repositories(site_repository)
     2. BiocManager:::.version_validate(version)
     4. BiocManager:::.stop(txt)
    
     ── 7. Failure: BiocVersion version matches with .version_map() (@test_version.R#
     BiocVersion package version '3.10' does not match BiocManager::.version_map() '3.11'. Check configuration.
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     [ OK: 72 | SKIPPED: 2 | WARNINGS: 0 | FAILED: 7 ]
     1. Error: .install_repos() works (@test_install.R#28)
     2. Error: .install_github() works (@test_install.R#35)
     3. Error: repositories() returns all repos (@test_repositories.R#7)
     4. Error: repositories() does not return any NA repos (@test_repositories.R#13)
     5. Error: repositories() returns expected order (@test_repositories.R#19)
     6. Error: 'site_repository=' inserted correctly (@test_repositories.R#26)
     7. Failure: BiocVersion version matches with .version_map() (@test_version.R#176)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-devel-linux-x86_64-debian-gcc

Version: 1.30.9
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘BiocVersion’
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.30.9
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'BiocStyle', 'BiocVersion'
Flavor: r-release-osx-x86_64

Version: 1.30.9
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     ‘BiocStyle’ ‘BiocVersion’
Flavor: r-oldrel-osx-x86_64