CRAN Package Check Results for Package Biocomb

Last updated on 2018-01-18 19:49:36 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.3 40.75 150.94 191.69 OK
r-devel-linux-x86_64-debian-gcc 0.3 32.70 130.38 163.08 OK
r-devel-linux-x86_64-fedora-clang 0.3 259.75 OK
r-devel-linux-x86_64-fedora-gcc 0.3 266.94 OK
r-devel-windows-ix86+x86_64 0.3 76.00 233.00 309.00 OK
r-patched-linux-x86_64 0.3 39.11 175.33 214.44 OK
r-patched-solaris-x86 0.3 3.60 ERROR
r-release-linux-x86_64 0.3 38.23 175.39 213.62 OK
r-release-windows-ix86+x86_64 0.3 81.00 213.00 294.00 OK
r-release-osx-x86_64 0.3 OK
r-oldrel-windows-ix86+x86_64 0.3 83.00 188.00 271.00 OK
r-oldrel-osx-x86_64 0.3 ERROR

Check Details

Version: 0.3
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘FSelector’ ‘RWeka’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-patched-solaris-x86

Version: 0.3
Check: examples
Result: ERROR
    Running examples in ‘Biocomb-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: Biocomb-package
    > ### Title: Tools for Data Mining
    > ### Aliases: Biocomb-package Biocomb
    > ### Keywords: package feature selection classification information gain
    > ### Relative cost curves HUM roc auc
    >
    > ### ** Examples
    >
    > data(data_test)
    > # class label must be factor
    > data_test[,ncol(data_test)]<-as.factor(data_test[,ncol(data_test)])
    >
    > # Perform the feature selection using the fast correlation-based filter algorithm
    > disc="MDL"
    > threshold=0.2
    > attrs.nominal=numeric()
    > out=select.fast.filter(data_test,disc.method=disc,threshold=threshold,
    + attrs.nominal=attrs.nominal)
    Error in .jnew("weka/core/Attribute", attname[i], .jcast(levels, "java/util/List")) :
     java.lang.UnsupportedClassVersionError: weka/core/Attribute : Unsupported major.minor version 51.0
    Calls: select.fast.filter ... read_model_frame_into_Weka -> read_data_into_Weka -> .jnew -> .External
    Execution halted
Flavor: r-oldrel-osx-x86_64