CRAN Package Check Results for Package GenCAT

Last updated on 2018-05-23 03:48:22 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-oldrel-osx-x86_64 1.0.3 ERROR

Check Details

Version: 1.0.3
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘snpStats’
Flavor: r-oldrel-osx-x86_64

Version: 1.0.3
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘snpStats’
Flavor: r-oldrel-osx-x86_64

Version: 1.0.3
Check: data for non-ASCII characters
Result: NOTE
     Error in .requirePackage(package) :
     unable to find required package 'snpStats'
     Calls: <Anonymous> ... .extendsForS3 -> extends -> getClassDef -> .requirePackage
     Execution halted
Flavor: r-oldrel-osx-x86_64

Version: 1.0.3
Check: examples
Result: ERROR
    Running examples in ‘GenCAT-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: GenCAT
    > ### Title: Running GenCAT
    > ### Aliases: GenCAT
    > ### Keywords: ~kwd1 ~kwd2
    >
    > ### ** Examples
    >
    >
    > ###############
    > #Running GenCAT
    > ###############
    > data("CardioMapped")
    >
    > #Subset CardioMapped to decrease CPU time
    > CardioMappedSub<-CardioMapped[CardioMapped$chr < 15,]
    > set.seed(1)
    > CardioMappedSub<-CardioMappedSub[sample(1:nrow(CardioMappedSub), 100),]
    >
    > print(head(CardioMappedSub))
     SNP effect_allele other_allele testStat chr position class
    17232 rs9572807 C T -0.3014771 13 72423959 DACH1
    24151 rs4389009 G A -1.4443860 13 99193519 STK24
    37178 rs7151730 T A 0.1387317 14 33531585 NPAS3
    58941 rs1076958 G A 2.0597766 14 91131857 TTC7B
    13089 rs7987481 G A -1.0024210 13 47318950 LRCH1
    58302 rs411064 G A 0.2132412 14 90008860 FOXN3
    >
    > library(snpStats)
    Error in library(snpStats) : there is no package called ‘snpStats’
    Execution halted
Flavor: r-oldrel-osx-x86_64

Version: 1.0.3
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: dplyr
    
    Attaching package: 'dplyr'
    
    The following objects are masked from 'package:stats':
    
     filter, lag
    
    The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
    Loading required package: doParallel
    Loading required package: foreach
    Loading required package: iterators
    Loading required package: parallel
    Loading required package: ggplot2
    Quitting from lines 62-69 (GenCAT-vignette.Rmd)
    Error: processing vignette 'GenCAT-vignette.Rmd' failed with diagnostics:
    unable to find required package 'snpStats'
    Execution halted
Flavor: r-oldrel-osx-x86_64