CRAN Package Check Results for Package Gmisc

Last updated on 2018-05-27 09:48:02 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.6.1 34.99 143.18 178.17 WARN
r-devel-linux-x86_64-debian-gcc 1.6.1 30.61 111.21 141.82 WARN
r-devel-linux-x86_64-fedora-clang 1.6.1 218.78 OK
r-devel-linux-x86_64-fedora-gcc 1.6.1 207.97 OK
r-devel-windows-ix86+x86_64 1.6.1 63.00 186.00 249.00 OK
r-patched-linux-x86_64 1.6.1 36.21 122.74 158.95 OK
r-patched-solaris-x86 1.6.1 245.80 OK --no-tests
r-release-linux-x86_64 1.6.1 36.60 122.53 159.13 OK
r-release-windows-ix86+x86_64 1.6.1 92.00 241.00 333.00 OK
r-release-osx-x86_64 1.6.1 OK
r-oldrel-windows-ix86+x86_64 1.6.1 88.00 203.00 291.00 OK
r-oldrel-osx-x86_64 1.5 ERROR

Check Details

Version: 1.6.1
Check: for unstated dependencies in ‘tests’
Result: WARN
    'library' or 'require' call not declared from: ‘stringr’
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 1.5
Check: tests
Result: ERROR
     Running ‘testthat.R’ [6s/6s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     Loading required package: Gmisc
     Loading required package: Rcpp
     Loading required package: htmlTable
     ── 1. Error: (unknown) (@test-fig_caption.R#6) ────────────────────────────────
     pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
     1: rmarkdown::render(fn, output_file = file.path(td, "tmp.html")) at testthat/test-fig_caption.R:6
     2: pandoc_available(required_pandoc, error = TRUE)
     3: stop(paste(msg, collapse = " "), call. = FALSE)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     OK: 311 SKIPPED: 0 FAILED: 1
     1. Error: (unknown) (@test-fig_caption.R#6)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-oldrel-osx-x86_64