CRAN Package Check Results for Package OptimModel

Last updated on 2024-06-13 15:48:31 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.0-1 8.64 97.44 106.08 OK
r-devel-linux-x86_64-debian-gcc 2.0-1 7.64 62.62 70.26 ERROR
r-devel-linux-x86_64-fedora-clang 2.0-1 138.73 OK
r-devel-linux-x86_64-fedora-gcc 2.0-1 138.66 OK
r-devel-windows-x86_64 2.0-1 8.00 90.00 98.00 OK
r-patched-linux-x86_64 2.0-1 8.54 94.34 102.88 OK
r-release-linux-x86_64 2.0-1 7.37 93.52 100.89 OK
r-release-macos-arm64 2.0-1 44.00 OK
r-release-macos-x86_64 2.0-1 85.00 OK
r-release-windows-x86_64 2.0-1 9.00 91.00 100.00 OK
r-oldrel-macos-arm64 2.0-1 49.00 OK
r-oldrel-macos-x86_64 2.0-1 98.00 OK
r-oldrel-windows-x86_64 2.0-1 7.00 114.00 121.00 OK

Check Details

Version: 2.0-1
Check: package dependencies
Result: NOTE Packages suggested but not available for checking: 'testthat', 'ggplot2' Flavor: r-devel-linux-x86_64-debian-gcc

Version: 2.0-1
Check: tests
Result: ERROR Running ‘testthat.R’ [0s/1s] Running the tests in ‘tests/testthat.R’ failed. Complete output: > # This file is part of the standard setup for testthat. > # It is recommended that you do not modify it. > # > # Where should you do additional test configuration? > # Learn more about the roles of various files in: > # * https://r-pkgs.org/testing-design.html#sec-tests-files-overview > # * https://testthat.r-lib.org/articles/special-files.html > require('testthat') Loading required package: testthat Warning message: In library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, : there is no package called 'testthat' > test_check("OptimModel") Error in test_check("OptimModel") : could not find function "test_check" Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 2.0-1
Check: re-building of vignette outputs
Result: ERROR Error(s) in re-building vignettes: ... --- re-building ‘OptimModel_vignette.Rmd’ using rmarkdown Quitting from lines 219-254 [unnamed-chunk-4] (OptimModel_vignette.Rmd) Error: processing vignette 'OptimModel_vignette.Rmd' failed with diagnostics: there is no package called 'ggplot2' --- failed re-building ‘OptimModel_vignette.Rmd’ SUMMARY: processing the following file failed: ‘OptimModel_vignette.Rmd’ Error: Vignette re-building failed. Execution halted Flavor: r-devel-linux-x86_64-debian-gcc