CRAN Package Check Results for Package PCRedux

Last updated on 2018-10-22 22:56:49 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.6-1 16.08 463.33 479.41 WARN
r-devel-linux-x86_64-debian-gcc 0.2.6-1 10.76 360.89 371.65 WARN
r-devel-linux-x86_64-fedora-clang 0.2.6-1 592.15 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.6-1 595.66 NOTE
r-devel-windows-ix86+x86_64 0.2.6-1 37.00 417.00 454.00 NOTE
r-patched-linux-x86_64 0.2.6-1 9.85 463.70 473.55 OK
r-patched-solaris-x86 0.2.6-1 446.40 NOTE
r-release-linux-x86_64 0.2.6-1 0.84 2.22 3.06 ERROR
r-release-windows-ix86+x86_64 0.2.6-1 46.00 378.00 424.00 NOTE
r-release-osx-x86_64 0.2.6-1 WARN
r-oldrel-windows-ix86+x86_64 0.2.6-1 36.00 300.00 336.00 NOTE
r-oldrel-osx-x86_64 0.2.6-1 WARN

Check Details

Version: 0.2.6-1
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Quitting from lines 2259-2294 (PCRedux.Rmd)
    Error: processing vignette ‘PCRedux.Rmd’ failed with diagnostics:
    replacement has 2 rows, data has 1
    Execution halted
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 0.2.6-1
Check: installed package size
Result: NOTE
     installed size is 5.5Mb
     sub-directories of 1Mb or more:
     doc 3.9Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-x86, r-release-windows-ix86+x86_64, r-release-osx-x86_64, r-oldrel-windows-ix86+x86_64, r-oldrel-osx-x86_64

Version: 0.2.6-1
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘caret’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.2.6-1
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘plotly’ ‘qpcR’ ‘visdat’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-linux-x86_64

Version: 0.2.6-1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Warning: 'rgl_init' failed, running with rgl.useNULL = TRUE
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64