CRAN Package Check Results for Package cthist

Last updated on 2022-05-25 23:10:06 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.0 4.06 55.98 60.04 OK
r-devel-linux-x86_64-debian-gcc 1.0.0 3.64 43.05 46.69 OK
r-devel-linux-x86_64-fedora-clang 1.0.0 69.97 OK
r-devel-linux-x86_64-fedora-gcc 1.0.0 72.48 OK
r-devel-windows-x86_64 1.0.0 66.00 124.00 190.00 OK
r-patched-linux-x86_64 1.0.0 4.39 53.84 58.23 OK
r-release-linux-x86_64 1.0.0 ERROR
r-release-macos-arm64 1.0.0 110.00 OK
r-release-macos-x86_64 1.0.0 112.00 OK
r-release-windows-x86_64 1.0.0 34.00 121.00 155.00 OK
r-oldrel-macos-arm64 1.0.0 90.00 OK
r-oldrel-macos-x86_64 1.0.0 100.00 OK
r-oldrel-windows-ix86+x86_64 1.0.0 11.00 115.00 126.00 OK

Check Details

Version: 1.0.0
Check: tests
Result: ERROR
     Running ‘testthat.R’ [15s/362s]
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > library(testthat)
     > library(cthist)
     >
     > test_check("cthist")
     Error downloading NCT ID: NCT02329873
     Here's the original error message:
     Error in curl::curl_fetch_memory(url, handle = handle): Error in the HTTP2 framing layer
    
    
     Error downloading version: NCT02110043 version 1
     Here's the original error message:
     Error in curl::curl_fetch_memory(url, handle = handle): Error in the HTTP2 framing layer
    
    
     Error downloading version: NCT05306145 version 1
     Here's the original error message:
     Error in curl::curl_fetch_memory(url, handle = handle): Error in the HTTP2 framing layer
    
    
     DRKS ID caused a warning: DRKS00005219
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/navigate.do?navigationId=trial.history&TRIAL_ID=DRKS00005219
    
    
     DRKS ID caused a warning: DRKS00003961
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/navigate.do?navigationId=trial.history&TRIAL_ID=DRKS00003961
    
    
     Version caused a warning: DRKS00003961 version 0
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00003961&version1=DRKS00003961_en.html&version2=DRKS00003961_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00004013 version 14
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00004013&version1=DRKS00004013_14_en.html&version2=DRKS00004013_14_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00004013 version 14
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00004013&version1=DRKS00004013_14_en.html&version2=DRKS00004013_14_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00015220 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00015220&version1=DRKS00015220_2_en.html&version2=DRKS00015220_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     Version caused a warning: DRKS00005219 version 2
     Here's the original warning message:
     simpleWarning: Server error: (503) Service Unavailable https://drks.de/drks_web/compareTrialVersions.do?TRIAL_ID=DRKS00005219&version1=DRKS00005219_2_en.html&version2=DRKS00005219_2_en.html
    
    
     [ FAIL 16 | WARN 1 | SKIP 0 | PASS 19 ]
    
     ══ Failed tests ════════════════════════════════════════════════════════════════
     ── Failure (test-drks_de_dates.R:3:5): DRKS version dates download correctly ───
     "2014-04-17" %in% result || result == "Error" (`actual`) not equal to TRUE (`expected`).
    
     `actual`: FALSE
     `expected`: TRUE
     ── Error (test-drks_de_download.R:6:5): DRKS.de history entries mass-download correctly ──
     Error in `versiondata$rstatus`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─cthist::drks_de_download(c("DRKS00003961"), filename, TRUE) at test-drks_de_download.R:6:4
     2. │ ├─... %>% ...
     3. │ └─tibble::tribble(...)
     4. │ └─tibble:::extract_frame_data_from_dots(...)
     5. │ └─rlang::list2(...)
     6. └─readr::write_csv(., file = output_filename, append = TRUE)
     7. └─readr::write_delim(...)
     8. ├─base::stopifnot(is.data.frame(x))
     9. └─base::is.data.frame(x)
     ── Failure (test-drks_de_version.R:3:5): DRKS.de version downloads correctly ───
     length(result) == 13 || result == "Error" (`actual`) not equal to TRUE (`expected`).
    
     `actual`: FALSE
     `expected`: TRUE
     ── Error (test-drks_de_version_closingdate.R:9:9): DRKS closing date downloads correctly ──
     Error in `version$closingdate`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$closingdate, "2014-09-01") at test-drks_de_version_closingdate.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_contacts.R:9:9): DRKS contacts download correctly ──
     Error in `version$contacts`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─testthat::expect_equal(...) at test-drks_de_version_contacts.R:9:8
     2. │ └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─jsonlite::fromJSON(version$contacts)
     ── Error (test-drks_de_version_enrolno.R:9:9): DRKS enrolment number downloads correctly ──
     Error in `version$enrolno`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$enrolno, "300") at test-drks_de_version_enrolno.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_enroltype.R:9:9): DRKS enrolment type downloads correctly ──
     Error in `version$enroltype`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$enroltype, "Actual") at test-drks_de_version_enroltype.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_exclusion_criteria.R:9:9): DRKS inclusion criteria download correctly ──
     Error in `version$exclusion_criteria`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─testthat::expect_equal(...) at test-drks_de_version_exclusion_criteria.R:9:8
     2. │ └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─jsonlite::fromJSON(version$exclusion_criteria)
     ── Error (test-drks_de_version_gender.R:9:9): DRKS gender downloads correctly ──
     Error in `version$gender`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$gender, "Male") at test-drks_de_version_gender.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_inclusion_criteria.R:9:9): DRKS inclusion criteria download correctly ──
     Error in `version$inclusion_criteria`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─testthat::expect_equal(...) at test-drks_de_version_inclusion_criteria.R:9:8
     2. │ └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─jsonlite::fromJSON(version$inclusion_criteria)
     ── Error (test-drks_de_version_max_age.R:9:9): DRKS maximum age downloads correctly ──
     Error in `version$max_age`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$max_age, "35 Years") at test-drks_de_version_max_age.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_min_age.R:9:9): DRKS minimum age downloads correctly ──
     Error in `version$min_age`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$min_age, "18 Years") at test-drks_de_version_min_age.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_primaryoutcomes.R:9:9): DRKS primary outcomes download correctly ──
     Error in `version$primaryoutcomes`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─testthat::expect_equal(...) at test-drks_de_version_primaryoutcomes.R:9:8
     2. │ └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─jsonlite::fromJSON(version$primaryoutcomes)
     ── Error (test-drks_de_version_rstatus.R:9:9): DRKS recruitment status downloads correctly ──
     Error in `version$rstatus`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$rstatus, "Recruiting complete, follow-up complete") at test-drks_de_version_rstatus.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
     ── Error (test-drks_de_version_secondaryoutcomes.R:9:9): DRKS secondary outcomes download correctly ──
     Error in `version$secondaryoutcomes`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. ├─testthat::expect_equal(...) at test-drks_de_version_secondaryoutcomes.R:9:8
     2. │ └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. │ └─rlang::eval_bare(expr, quo_get_env(quo))
     4. └─jsonlite::fromJSON(version$secondaryoutcomes)
     ── Error (test-drks_de_version_startdate.R:9:9): DRKS start date downloads correctly ──
     Error in `version$startdate`: $ operator is invalid for atomic vectors
     Backtrace:
     ▆
     1. └─testthat::expect_equal(version$startdate, "2013-08-09") at test-drks_de_version_startdate.R:9:8
     2. └─testthat::quasi_label(enquo(object), label, arg = "object")
     3. └─rlang::eval_bare(expr, quo_get_env(quo))
    
     [ FAIL 16 | WARN 1 | SKIP 0 | PASS 19 ]
     Error: Test failures
     Execution halted
Flavor: r-release-linux-x86_64