CRAN Package Check Results for Package dataMaid

Last updated on 2019-02-15 22:46:35 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2.0 5.78 68.03 73.81 OK
r-devel-linux-x86_64-debian-gcc 1.2.0 5.47 53.35 58.82 OK
r-devel-linux-x86_64-fedora-clang 1.2.0 95.40 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2.0 86.11 NOTE
r-devel-windows-ix86+x86_64 1.2.0 18.00 118.00 136.00 OK
r-patched-linux-x86_64 1.2.0 5.17 63.23 68.40 OK
r-patched-solaris-x86 1.2.0 117.10 WARN
r-release-linux-x86_64 1.2.0 5.18 63.92 69.10 OK
r-release-windows-ix86+x86_64 1.2.0 11.00 84.00 95.00 OK
r-release-osx-x86_64 1.2.0 WARN
r-oldrel-windows-ix86+x86_64 1.2.0 23.00 130.00 153.00 OK
r-oldrel-osx-x86_64 1.2.0 ERROR

Check Details

Version: 1.2.0
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘DT’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64

Version: 1.2.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    sh: whoami: not found
    sh: git: not found
    sh: git: not found
    Data report generation is finished. Please wait while your output file is being rendered.
    Quitting from lines 729-768 (extending_dataMaid.Rmd)
    Error: processing vignette 'extending_dataMaid.Rmd' failed with diagnostics:
    pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
    Execution halted
Flavor: r-patched-solaris-x86

Version: 1.2.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Data report generation is finished. Please wait while your output file is being rendered.
    Quitting from lines 729-768 (extending_dataMaid.Rmd)
    Error: processing vignette 'extending_dataMaid.Rmd' failed with diagnostics:
    pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
    Execution halted
Flavor: r-release-osx-x86_64

Version: 1.2.0
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘robustbase’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-osx-x86_64