CRAN Package Check Results for Package ggiraphExtra

Last updated on 2018-08-21 12:50:29 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.9 10.72 187.42 198.14 OK
r-devel-linux-x86_64-debian-gcc 0.2.9 10.35 146.41 156.76 OK
r-devel-linux-x86_64-fedora-clang 0.2.9 241.44 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.9 231.90 NOTE
r-devel-windows-ix86+x86_64 0.2.9 36.00 284.00 320.00 OK
r-patched-linux-x86_64 0.2.9 10.13 171.28 181.41 OK
r-patched-solaris-x86 0.2.9 272.50 WARN
r-release-linux-x86_64 0.2.9 11.04 172.48 183.52 OK
r-release-windows-ix86+x86_64 0.2.9 29.00 210.00 239.00 OK
r-release-osx-x86_64 0.2.9 WARN
r-oldrel-windows-ix86+x86_64 0.2.9 17.00 311.00 328.00 OK
r-oldrel-osx-x86_64 0.2.9 WARN

Check Details

Version: 0.2.9
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘ggforce’ ‘webshot’ ‘ztable’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.2.9
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    Loading required package: ggiraph
    Loading required package: ggiraphExtra
    
    Attaching package: 'ggiraphExtra'
    
    The following objects are masked from 'package:moonBook':
    
     addLabelDf, getMapping
    
    Loading required package: plyr
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 45-49 (ggPredict.Rmd)
    Error: processing vignette 'ggPredict.Rmd' failed with diagnostics:
    cannot open the connection
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.2.9
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: ggplot2
    Loading required package: ggiraph
    Loading required package: ggiraphExtra
    Loading required package: plyr
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Quitting from lines 45-49 (ggPredict.Rmd)
    Error: processing vignette 'ggPredict.Rmd' failed with diagnostics:
    cannot open the connection
    Execution halted
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64