CRAN Package Check Results for Package memapp

Last updated on 2018-02-24 01:48:04 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.7 1.36 23.10 24.46 OK
r-devel-linux-x86_64-debian-gcc 2.7 0.90 18.94 19.84 OK
r-devel-linux-x86_64-fedora-clang 2.7 30.07 NOTE
r-devel-linux-x86_64-fedora-gcc 2.7 28.84 NOTE
r-devel-windows-ix86+x86_64 2.7 5.00 59.00 64.00 OK
r-patched-linux-x86_64 2.7 1.10 21.94 23.04 OK
r-patched-solaris-x86 2.7 41.20 NOTE
r-release-linux-x86_64 2.7 1.32 21.70 23.02 OK
r-release-windows-ix86+x86_64 2.7 9.00 52.00 61.00 OK
r-release-osx-x86_64 2.7 NOTE
r-oldrel-osx-x86_64 2.6 ERROR

Check Details

Version: 2.7
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘RColorBrewer’ ‘RODBC’ ‘dplyr’ ‘formattable’ ‘ggplot2’
     ‘ggthemes’ ‘magrittr’ ‘mem’ ‘openxlsx’ ‘plotly’ ‘readxl’ ‘shinyBS’
     ‘shinydashboard’ ‘shinyjs’ ‘shinythemes’ ‘stringi’ ‘stringr’ ‘tidyr’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64

Version: 2.7
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘magick’
Flavor: r-patched-solaris-x86

Version: 2.6
Check: package dependencies
Result: ERROR
    Package required but not available: ‘RODBC’
    
    Package required and available but unsuitable version: ‘mem’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-osx-x86_64