CRAN Package Check Results for Package oxcAAR

Last updated on 2018-05-26 16:47:56 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.0 1.76 58.73 60.49 OK
r-devel-linux-x86_64-debian-gcc 1.0.0 1.56 47.24 48.80 OK
r-devel-linux-x86_64-fedora-clang 1.0.0 82.65 OK
r-devel-linux-x86_64-fedora-gcc 1.0.0 54.53 OK
r-devel-windows-ix86+x86_64 1.0.0 4.00 85.00 89.00 OK
r-patched-linux-x86_64 1.0.0 1.25 42.70 43.95 OK
r-patched-solaris-x86 1.0.0 52.20 ERROR
r-release-linux-x86_64 1.0.0 2.08 42.43 44.51 OK
r-release-windows-ix86+x86_64 1.0.0 5.00 92.00 97.00 OK
r-release-osx-x86_64 1.0.0 OK
r-oldrel-windows-ix86+x86_64 1.0.0 4.00 83.00 87.00 OK
r-oldrel-osx-x86_64 1.0.0 OK

Check Details

Version: 1.0.0
Check: tests
Result: ERROR
     Running ‘testthat.R’
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > library(testthat)
     > library(oxcAAR)
     >
     > test_check("oxcAAR")
     sh: /home/ripley/R/packages/tests32/oxcAAR.Rcheck/tests/testthat/ox_output.js: cannot execute
     ── 1. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_util
     `quickSetupOxcal()` threw an error.
     Message: argument is of length zero
     Class: simpleError/error/condition
    
     ── 2. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_util
     dir.exists("OxCal/bin/") isn't true.
    
     ── 3. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_util
     `%in%`(...) isn't true.
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     OK: 94 SKIPPED: 0 FAILED: 3
     1. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_utility_functions.R#30)
     2. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_utility_functions.R#31)
     3. Failure: quickSetupOxcal downloads oxcal and sets correct path (@test_utility_functions.R#32)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-patched-solaris-x86

Version: 1.0.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     The vignette engine knitr::rmarkdown is not available, because the rmarkdown package is not installed. Please install it.
    Quitting from lines 24-30 (basic-usage.Rmd)
    Error: processing vignette 'basic-usage.Rmd' failed with diagnostics:
    argument is of length zero
    Execution halted
Flavor: r-patched-solaris-x86