CRAN Package Check Results for Package psycho

Last updated on 2018-05-26 16:47:59 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.3 10.77 468.56 479.33 OK
r-devel-linux-x86_64-debian-gcc 0.2.3 9.09 357.25 366.34 OK
r-devel-linux-x86_64-fedora-clang 0.2.3 590.95 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.3 567.47 NOTE
r-devel-windows-ix86+x86_64 0.2.3 22.00 469.00 491.00 OK
r-patched-linux-x86_64 0.2.3 8.78 427.91 436.69 OK
r-patched-solaris-x86 0.2.3 610.40 WARN
r-release-linux-x86_64 0.2.3 8.96 427.49 436.45 OK
r-release-windows-ix86+x86_64 0.2.3 30.00 616.00 646.00 OK
r-release-osx-x86_64 0.2.3 ERROR
r-oldrel-windows-ix86+x86_64 0.2.3 32.00 642.00 674.00 ERROR
r-oldrel-osx-x86_64 0.1.4 OK

Check Details

Version: 0.2.3
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘BayesFactor’ ‘methods’ ‘pbkrtest’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64

Version: 0.2.3
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: Rcpp
    rstanarm (Version 2.17.4, packaged: 2018-04-13 01:51:52 UTC)
    - Do not expect the default priors to remain the same in future rstanarm versions.
    Thus, R scripts should specify priors explicitly, even if they are just the defaults.
    - For execution on a local, multicore CPU with excess RAM we recommend calling
    options(mc.cores = parallel::detectCores())
    - Plotting theme set to bayesplot::theme_default().
    
    Attaching package: 'dplyr'
    
    The following objects are masked from 'package:stats':
    
     filter, lag
    
    The following objects are masked from 'package:base':
    
     intersect, setdiff, setequal, union
    
    Warning: There were 1 divergent transitions after warmup. Increasing adapt_delta above 0.95 may help. See
    http://mc-stan.org/misc/warnings.html#divergent-transitions-after-warmup
    Warning: Examine the pairs() plot to diagnose sampling problems
    
    
    Attaching package: 'plotly'
    
    The following object is masked from 'package:ggplot2':
    
     last_plot
    
    The following objects are masked from 'package:rstanarm':
    
     get_x, get_y
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    We recommend that you use the dev version of ggplot2 with `ggplotly()`
    Install it with: `devtools::install_github('hadley/ggplot2')`
    Quitting from lines 503-531 (bayesian.Rmd)
    Error: processing vignette 'bayesian.Rmd' failed with diagnostics:
    there is no package called 'webshot'
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.2.3
Check: tests
Result: ERROR
     Running ‘testthat.R’ [44s/44s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     Elapsed Time: 0.259586 seconds (Warm-up)
     0.40909 seconds (Sampling)
     0.668676 seconds (Total)
    
     .0%
     .33%
     .67%
     .100%
     1
     ══ testthat results ═══════════════════════════════════════════════════════════
     OK: 97 SKIPPED: 0 FAILED: 1
     1. Failure: If it works. (@test-analyze.stanreg.R#18)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-osx-x86_64

Version: 0.2.3
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
     last_plot
    
    The following objects are masked from 'package:rstanarm':
    
     get_x, get_y
    
    The following object is masked from 'package:stats':
    
     filter
    
    The following object is masked from 'package:graphics':
    
     layout
    
    We recommend that you use the dev version of ggplot2 with `ggplotly()`
    Install it with: `devtools::install_github('hadley/ggplot2')`
    PhantomJS not found. You can install it with webshot::install_phantomjs(). If it is installed, please make sure the phantomjs executable can be found via the PATH variable.
    Warning in normalizePath(f2) :
     path[1]="./webshot110554ed198ac.png": No such file or directory
    Warning in file(con, "rb") :
     cannot open file './webshot110554ed198ac.png': No such file or directory
    Quitting from lines 503-531 (bayesian.Rmd)
    Error: processing vignette 'bayesian.Rmd' failed with diagnostics:
    cannot open the connection
    Execution halted
Flavor: r-release-osx-x86_64

Version: 0.2.3
Check: for unstated dependencies in examples
Result: WARN
    Warning in parse(file = files, n = -1L) :
     invalid input found on input connection 'psycho-Ex.R'
Flavor: r-oldrel-windows-ix86+x86_64

Version: 0.2.3
Check: examples
Result: ERROR
    Running examples in 'psycho-Ex.R' failed
    The error occurred in:
    
    
    R version 3.4.4 (2018-03-15) -- "Someone to Lean On"
    Copyright (C) 2018 The R Foundation for Statistical Computing
    Platform: x86_64-w64-mingw32/x64 (64-bit)
    
    R is free software and comes with ABSOLUTELY NO WARRANTY.
    You are welcome to redistribute it under certain conditions.
    Type 'license()' or 'licence()' for distribution details.
    
     Natural language support but running in an English locale
    
    R is a collaborative project with many contributors.
    Type 'contributors()' for more information and
    'citation()' on how to cite R or R packages in publications.
    
    Type 'demo()' for some demos, 'help()' for on-line help, or
    'help.start()' for an HTML browser interface to help.
    Type 'q()' to quit R.
    
    > pkgname <- "psycho"
    > source(file.path(R.home("share"), "R", "examples-header.R"))
    > options(warn = 1)
    > options(pager = "console")
    > library('psycho')
    Error: package or namespace load failed for 'psycho' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.2-12 is already loaded, but >= 1.2.13 is required
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Version: 0.2.3
Check: tests
Result: ERROR
     Running 'testthat.R' [6s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(psycho)
     Error: package or namespace load failed for 'psycho' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.2-12 is already loaded, but >= 1.2.13 is required
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64