CRAN Package Check Results for Package sbart

Last updated on 2019-09-20 05:47:05 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.1 57.51 134.42 191.93 WARN
r-devel-linux-x86_64-debian-gcc 0.1.1 48.60 120.37 168.97 WARN
r-devel-linux-x86_64-fedora-clang 0.1.1 275.23 WARN
r-devel-linux-x86_64-fedora-gcc 0.1.1 267.97 WARN
r-devel-windows-ix86+x86_64 0.1.1 155.00 287.00 442.00 OK
r-patched-linux-x86_64 0.1.1 53.15 141.44 194.59 OK
r-patched-solaris-x86 0.1.1 485.10 OK
r-release-linux-x86_64 0.1.1 56.91 143.47 200.38 OK
r-release-windows-ix86+x86_64 0.1.1 96.00 272.00 368.00 OK
r-release-osx-x86_64 0.1.1 NOTE
r-oldrel-windows-ix86+x86_64 0.1.1 93.00 283.00 376.00 OK
r-oldrel-osx-x86_64 0.1.1 NOTE

Check Details

Version: 0.1.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::equal_to<float> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::equal_to<double> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::equal_to<int> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::equal_to<bool> >' is deprecated [-Wdeprecated-declarations]
Flavor: r-devel-linux-x86_64-debian-clang

Version: 0.1.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Eigen/src/Core/Functors.h:932:28: warning: ‘template<class _Operation> class std::binder2nd’ is deprecated [-Wdeprecated-declarations]
     Eigen/src/Core/Functors.h:936:28: warning: ‘template<class _Operation> class std::binder1st’ is deprecated [-Wdeprecated-declarations]
     Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: ‘template<class _Operation> class std::binder1st’ is deprecated [-Wdeprecated-declarations]
     Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:65:28: warning: ‘template<class _Operation> class std::binder1st’ is deprecated [-Wdeprecated-declarations]
     Eigen/src/Core/../plugins/ArrayCwiseUnaryOps.h:190:34: warning: ‘template<class _Operation> class std::binder2nd’ is deprecated [-Wdeprecated-declarations]
     Eigen/src/Core/../plugins/ArrayCwiseUnaryOps.h:192:30: warning: ‘template<class _Operation> class std::binder2nd’ is deprecated [-Wdeprecated-declarations]
Flavors: r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-gcc

Version: 0.1.1
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::__1::equal_to<float> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::__1::equal_to<double> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::__1::equal_to<int> >' is deprecated [-Wdeprecated-declarations]
     ./Eigen/src/Core/../plugins/MatrixCwiseUnaryOps.h:62:32: warning: 'binder1st<std::__1::equal_to<bool> >' is deprecated [-Wdeprecated-declarations]
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.1.1
Check: installed package size
Result: NOTE
     installed size is 9.6Mb
     sub-directories of 1Mb or more:
     libs 9.5Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-release-osx-x86_64, r-oldrel-osx-x86_64